Conditonner l'activation d'un relais par une entrée digitale

Texte modifié : entrées digitales et pas analogiques !!!

Bonjour,
Je crois que je veux faire quelque chose de simple avec mon IPX800V4 mais je ne trouve pas la solution…

J’ai un relais qui commande l’alimentation d’un moteur de toit ouvrant. J’ai un autre relais qui est « la » commande d’ouverture / fermeture du toit. Si le 1er est OFF, le 2ème ne peut pas activer le moteur qui n’est pas alimenté.

Je dois conditionner l’état ON ou OFF du 1er, celui qui alimente ou pas le moteur du toit.

Si rien ne gêne l’ouverture, le relais doit être ON, moteur alimenté.
Si quelque chose gêne l’ouverture, le relais doit être OFF, moteur non alimenté.

Cette condition « gêne » ou « pas de gêne » est matérialisée par 2 entrées digitales,

  • les 2 à ON = pas de gêne = ouverture possible = moteur alimenté
  • l’1 des 2 ou les 2 à OFF = gêne = ouverture impossible = moteur non alimenté

Voilà, désolé, je pense que c’est basique…
Mais si quelqu’un peut m’aider…
A+
Bernard

Faire une regle du genre
Evenement : ED1 ET ED2
Action : ON/OFF
Resultat : Relais du Moteur

Cdt.

Ah merci,
J’ai déjà essayé ça. Je pars de la situation ED1 =1 et ED2 = 1. Quand ED1 passe à 0 il ne se passe rien, puis ED2 passe à 0, toujours rien, puis ED1 et ED2 repassent à 1 et là il y a action sur le relais.
Il n’y a une action que sur le statut 1.
Précision : ce relais agit en fait comme un télérupteur qui envoie une impulsion à un relais 12V/220V pour le faire basculer, 1 impulsion il ferme le circuit 220V et le moteur est alimenté, 1 impulsion il ouvre le circuit et le moteur n’est plus alimenté, etc… J’ai dû mettre un Tb à 5 pour avoir l’effet télérupteur sur ce relais IPX.
Peut être est ce dû à ça ? Mais je ne vois pas pourquoi…

En fait mon besoin c’est de n’autoriser le mouvement du toit, que quand ED1 ET ED2 sont à 1. C’est une sécurité.
Je pourrai aussi l’appliquer à la commande du toit, si ED1 ET ED2 = 0 ==> pas de commande possible, mais ça revient au même…

oui, c’est la nature de ce relais qui agit sur un relais 12V/220V qui pose problème. Je viens de tester le scénario basique en mettant simplement un relais libre et il bascule bien à chaque passage de l’équation logique de 1 à 0 etc…
si je mets un Tb de 5sec à ce relais, j’ai le même résultat, ça bascule pas
le pb c’est que ce relais passe à 1 puis revient à 0 après 5sec…

Bon j’ai trouvé une solution qui fonctionne.
2 scénarios.
S1 qui teste NON ED1 OU NON ED2 et actionne le relais
S2 qui teste ED1 ET ED2 et actionne le relais
problème, c’est qu’il faut partir d’une situation valable, parce que ces 2 scénarios ne font que changer l’état du relais en envoyant une impulsion dessus.
donc ce n’est pas une garantie que le toit ne peut s’ouvrir si ED1 ET ED2 ne sont pas à 1.
mais au moins ça marche…
Si quelqu’un voit plus simple : interdire une action sur un relais selon plusieurs conditions digitales.