Demande assistance pour Caméra HIKVISION

IPX800-V4 : Versions Firmware & Logicielle = V4.04.04
Caméra PTZ HIKVISION référence : DS-2DE2A404IW-DE3

Bonjour,
J’ai créé ce nouveau post car je ne sais pas dans lequel m’immiscer tant il y a de sujets qui traitent des caméras.
J’ai enfin réussi après moult tâtonnements et infos glanées un peu partout à afficher la vidéo dans un widget dédié. Je remercie au passage tous ceux qui m’ont donné des pistes en publiant leurs posts en donnant des solutions.
Mon problème actuel est que je ne sais pas comment faire pour piloter le déplacement de la caméra, soit au moyen d’impulsions, droite, gauche, soit en faisant appel à des presets configurés dans la caméra. Je ne sais pas si c’est clair :thinking:
Peut-être y a-t-il dans la communauté, une ou plusieurs personnes confrontées au même problème ? Leur aide me serait bien utile. Merci par avance.

Bonjour,

voici des url trouvées sur internet

PTZ/channels/1/PTZControl?command=PAN_LEFT&speed=1&mode=start
PTZ/channels/1/PTZControl?command=PAN_RIGHT&speed=1&mode=start
PTZ/channels/1/PTZControl?command=TILT_UP&speed=1&mode=start
PTZ/channels/1/PTZControl?command=TILT_DOWN&speed=1&mode=start
PTZ/channels/1/PTZControl?command=GOTO_PRESET&presetNo=1&speed=1&mode=stop

cdt

3 J'aime

Bonjour @fgtoul

C’est trop fort ! :slightly_smiling_face:
Un grand merci. Je vais passer une bonne journée :wink:
Où avez-vous trouvé ces infos, si ce n’est pas indiscret ?
Encore merci, bien cordialement.

1 J'aime

via une recherche google

1 J'aime

Un autre merci. Je vais investiguer sur ce forum…
Bonne journée.

1 J'aime

Bonjour,

La caméra est elle alimentée par un nvr ?

Merci

Bonjour @jnseie
Non, la caméra est alimentée en PoE.
Cdlt.

Est ce que ça aurait pu fonctionner si elle était en aval d’un nvr ?

Ne pas confondre 2 choses
Alimentation

  • soit direct
  • soit PoE sur bloc secteur ou sur NVR

Signal

  • soit direct
  • soit relié au NVR
    Le signal ne peut pas aller à 2 endroits différents (sauf matériel complémentaire)

Ensuite, pour raccorder le NVR sur l’IPX800, il faut avoir son flux vidéo, comme une caméra et se raccorder sur la sortie du NVR, pas sur une des entrées occupée par une caméra

Bonjour, je me permet de répondre à votre post.
car j’ai également acquis une caméra hikvision, en revanche je tente par tous les moyens d’afficher ma caméra dans un widget mais rien à faire.
http://admin:MDP@192.168.0.64:8002/Streaming/channels/1/preview
j’ai réussi avec plusieurs marques FOSCAM, HEDEN mais rien à faire.
j’ai cru comprendre que dans le menu de la caméra hikvision, il fallait cocher la case « activer CGI » mais ce menu intégration protocol est manquant.

Merci de votre aide

Bonjour,
Si vous voulez activer le CGI, il faut aller Réseau puis dans l’onglet Avancé.
Cordialement.

Avez-vous essayé avec …channels/102/…
Avez-vous configuré correctement le flux secondaire ?
Cdt

bonjour, merci
dans mon screenshot, dans l’onglet avantcé le protocol d’intégration est manquant. :frowning:
En revanche je viens de voir que le problème vient probablement de l’écriture.
car lorsque je me connecte sur la caméra via http url dans page de navigation, avec login+mdp j’obtiens mon flux video je rafraichis mon dashboard de l’ipx le flux vidéo dans le widget apparait ( que si j’ai bien fermé la page de navigation.
vraiment étrange…

image
j’ai intégré le login et mot de passe mais il me demande malgré tout de me logger :roll_eyes:
bizarre
http://admin:mdp@192.168.0.60:8002/streaming/channels/102/preview