Détecteur PIR éclairage Hue via X-24D avec Tempo

Bonjour,

J’essaie d’allumer une lampe Hue sur détéction de mouvement d’un capteur PIR 12v connecté à un X-24D.
Le X-24D détecte bien le mouvement : sur le dashboard v5, la led de l’entrée digitale passe bien à OFF lors de la détéction de mouvement.
Le lien vers mon ruban led Hue fonctionne : il s’allume lors de la détection de mouvement. Par contre il s’éteint au bout de 30s (TB programmé à 30s). J’aimerais que la tempo ne démarre que lorsqu’il n’y a plus de détection et qu’elle reparte à zéro en cas de nouvelle détection.

Voici ma config de Tempo :


J’imagine que j’ai un paramètre à modifier ?

Question subsidiaire sur le plugin Hue, dans le wiki v5 « Configuration du plugin « HUE Light » » on voit le nom des lampes est personnalisé (« Hue Chambre 1 »). Comment modifier le nom des lampes Hue ?

Merci,

Bonjour,
c’est bien le mode Hold qui convient dans ce cas.
Essayez d’activer le « contrôle bloqué après démarrage »

Voir l’objet Tempo dans ce wiki :
IHM V5 en détails : Les ressources et les liens — GCE Electronics (gce-electronics.com)

Un capteur PIR 12V sur un X-24D, ça passe @fgtoul ?

Merci @fgtoul c’était la page de doc que je cherchais.
J’étais sur la page wiki de la v5 IPX800 V5 — GCE Electronics et je ne voyais pas le détail de l’objet Tempo.

De ce que je comprends, je devrais déjà être dans la bonne config : le fonctionnement que je recherche c’est le premier example contrôle normal avec Mode HOLD (Si Pulse sur entrée, TB réinitialisé)
Dans le cas « contrôle bloqué après démarrage », si j’ai une nouvelle détection dans l’intervalle TB, le elle n’est pas prise en compte. Dans mon cas je veux que le décompte du TB ne démarre qu’après la fin de détection (qd ED repasse à 1)

Le fonctionnement que je recherche : ED passe à 0 => hue ON, ED reste à 0 => hue ON, ED passe à 1 => hue OFF après TB

Avec la config actuelle, si ED reste à 0 => j’ai hue OFF après TB

Oui j’en ai plusieurs sur le X-24D branché à ma v4, ça ne pose aucun problème. L’ED du X-24D est branchée sur la borne « Alarme » NC/NO.
Mon problème c’est plus la gestion du lien dans la v5. Sur v4 je le fais déjà.

ça passe si c’est un contact sec, sinon il faut une X24U.

1 « J'aime »

vous pouvez utiliser la tuile NON dans un scénario, ou bien un lien NOT.

@fgtoul j’ai déjà le NOT sur le lien X-24D vers Tempo.
Mode HOLD, Contrôle normal.

Tant que ma détection est active (ED X-24D= 0) la sortie de la Tempo devrait rester active ?
C’est ce que je comprends dans le wiki mais pas ce que j’ai en réalité … La sortie de la Tempo revient à 0 après la durée TB même si l’entrée reste à 1 (détection active => NOT 0).

Ou alors il faut uniquement que ça soit une impulsion ? Mon entrée ne revient pas à 0, elle reste à 1 (en gros j’ai un état haut sur l’entrée de le Tempo tant que j’ai une détection active)

Sur la v4 ça fonctionne parfaitement avec 2 scènes :

  • Scene 1 : NON ED1 => ON SV
  • Scène 2 : SV => ON/OFF PWM
    Avec SV TB = 30

Rappels importants :

  • En mode HOLD, l’entrée START de l’objet Tempo est en mode impulsionnel, elle retombe à OFF immédiatement après son passage à ON, peu importe l’état de l’objet liée (x24d dans votre cas)
  • En mode ON/OFF, la sortie suit l’état de l’entrée Start en cas d’interruption
  • en mode bloqué, la tempo continue son décompte quoi qu’il arrive sur son entrée Start.

ça c’est du mode HOLD en contrôle Normal. voir les chronogrammes
Du coup l’entrée est en mode impulsionnel. donc elle ne suit pas l’état de la X24D.

Sauf erreur, vu que vous ne prenez que le front montant avec la commande ON, votre scène V4 correspond sur V5 à un mode HOLD en contrôle Normal et dans ce mode il y a bien réinit du décompte mais si l’entrée restait OFF (donc NON ED = on) et qu’il n’y avait plus de changement d’état pendant le décompte, je pense que la tempo poursuivait son décompte et provoquait l’extinction, contrairement à ce que vous souhaitez aujourd’hui.
Voici le chronogramme de la scène V4 avec un TB 4 secondes
image

C’est exactement ce que l’on obtient sur la V5 en mode HOLD avec contrôle Normal

Si vous souhaitez un comportement différent de ceux obtenus par liens sur la V5, il faut donc passer par le moteur de scénario.

  1. Supprimez les liens entre ED, Tempo et Hue
  2. Passez la tempo en mode Hold, contrôle normal
  3. Testez les règles suivantes
    • Allumage Hue immédiat :
      NON ED ON HUE
    • Fin détection ; départ tempo
      ED ON TEMPO.START (mode hold)
    • Fin tempo et pas de détection :
      NON TEMPO.OUTPUT ET ED OFF HUE
1 « J'aime »

Voici l’équivalence par liens :