Hostname sur IPX800_V3 inopérant

Bonjour à toute la communauté,

Pour faire court, mon problème est que mon IPX800_V3 n’est pas adressage par son hostname programmé dans l’interface (voir image).

Il est censé être adressable par http://IPX800_V3 (comme le dit l’écran de validation des paramètres réseau)

Cependant ce n’est pas le cas.

Mon routeur (une livebox) qui intègre un serveur DHCP (et pas un DNS comme tu l’as dit initialement idiot :wink:), ne reconnait pas son adresse IP comme associée à un nom « IPX800_V3 ». J’ai plutôt un nom attribué genre PC-509.home.

La version de mon firmware est 3.05.70.

Est-ce que quelqu’un a le même problème ou connait la solution pour exploiter le HostName de ce serveur ? Ca évite de mettre en dure dans une programmation, l’adresse IP de l’automate.

Merci d’avance pour les réponses

Bonjour et bienvenue sur le forum

Je pense que vous confondez 2 notions.

  • le nom NetBios (Hostname)
  • le Nom d’Hôte (Hostname) sur un domaine

Le Hostname renseigné sur cet écran est le nom Netbios de l’ipx800. Il n’est visible que sur le réseau local sous certaines conditions : renseigner un fichier Hostname ou installer un serveur de noms (par exemple Wins)

Je ne pense pas que votre Livebox intégre un serveur DNS, mais plutôt un client DYNDNS (ou DDNS), ce qui est totalement différent. En général, les DNS (primaire et secondaire) sont chez le FAI. Certains particuliers ou les entreprises peuvent installer un serveur DNS, mais je ne pense pas que ce soit votre cas, en tout cas, pas avec une Livebox.
Quoi qu’il en soit, un serveur DNS n’est pas Plug & Play. Il faudra renseigner une table faisant correspondre le Hostname à une adresse IP.
Donc, si vous avez créé un compte DDNS chez un fournisseur (NO-IP par exemple), vous devez créer aussi le Hostname chez eux, pointant sur l’IP publique de votre IPX800.

Pour vous aider, je vous invite à consulter ce wiki

cdt

1 J'aime

Merci pour la réponse, mais je ne pense pas confondre les 2 notions.
En revanche j’ai fait une erreur (un lapsus ? :wink: ) dans mon post initial.
Il faut lire « Mon routeur qui intègre un DHCP au lieu de DNS ».

Mon propos n’est absolument pas d’avoir la capacité d’adresser le IPX800 depuis l’extérieur (internet) malgré une adresse IP Dynamique de mon abonnement internet.

Je veux juste que sur mon réseau local, je puisse adresser le IPX800 quelque soit l’adresse IP que le serveur DHCP lui a attribué. L’usage du « hostname » permet cela.

Selon votre réponse, je vois la référence à Netbios. Cela m’étonne car Netbios est plutôt utilisé par Microsoft (Windows). En natif, pour le monde Linux, netbios n’est pas « natif ».
Cela voudrait il dire que le nom ne sera visible que par des machines Windows ou d’autres avec les « surcoupées » réseau nécessaires ?

Ma réponse était effectivement basée sur la notion de DNS, que vous aviez utilisée par erreur (avant que vous ne corrigiez votre question initiale)

avez-vous renseigné le fichier /etc/hostname ?

Il y a bien une notion de DNS puisque c’est lui qui fait la résolution du nom de la machine pour connaître son adresse IP.
Le serveur DHCP prend connaissance du nom de la machine lorsque il lui attribue son adresse IP.
Si le serveur DHCP est bien configuré, il alimente la table du serveur DNS.
Je ne sais pas si la livebox est capable de faire cela.

Le DNS travaille avec des noms complets (hostname.domaine.com)

https://debian-handbook.info/browse/fr-FR/stable/sect.hostname-name-service.html

Oui bien sûr, mais dans ton LAN, ton serveur DNS connait ton nom de domaine par défaut et si tu ne le précise pas lors de ta requête c’est celui là qui sera alors utilisé pour faire la résolution.

merci , mais je sais comment fonctione un DNS :slight_smile:
je ne faisais que clarifier un peu certains points.

sur votre machine Linux, vous pouvez aussi installer Samba. Le package contient une commande Winbind qui force la reconnaissance des noms Windows.

La livebox est tout a fait capable d’enregistrer le hostname que lui envoi la machine à qui il attribue une adresse IP.
Il entretient en quelque sorte son propre /etc/hostname.

Mon problème est que bien que j’enregistre dans l’IPX le hostname que doit renvoyer l’IPX au serveur DHCP, ce nom n’apparait pas dans la livebox ou tout autre routeur (incluant un serveur DHCP) que j’ai utilisé.

J’ai comme l’impression que l’IPX800 utilise mal (ou pas du tout) le champ « hostname » qu’on renseigne dans les propriétés LAN de l’IPX800.
D’ailleurs je remarque que le champ a toujours 3 espaces à la fin du nom. Un bug ?

Vous vouliez dire /etc/hosts je suppose.
Cela ne répondra pas à mon besoin.
Si je dois renseigner le fichier /etc/hosts de la ou des machines du réseau qui doit(vent) consulter l’IPX800, je devrais renseigner en « dur » l’adresse IP de l’IPX800, ce que je cherche à éviter.
En effet, si le serveur DHCP attribue une nouvelle adresse à l’IPX800 (pour je ne sais quelle raison), tous les fichiers /etc/hosts devront être modifier.
Je refuse de fixer une adresse statiques sur l’IPX800 pour des raisons que je ne développe pas pour éviter d’embrouiller.

Pour rappel mon besoin est de pouvoir adresser l’IPX800 par son hostname quelque soit l’adresse IP qui lui est attribuer.

Tu as d’autres appareils qui fonctionnent comme tu le décris ?
Il faut voir avec @GCE, cela peut être le client DHCP de l’ipx qui ne fait pas complètement son boulot.

Ca aussi je voulais l’éviter.

Si je comprends bien, le ‹ hostname › que l’on renseigne dans les propriétés LAN de l’IPX800 sont uniquement réservé à Netbios ???

Je suis très dubitatif de ce besoin d’avoir besoin d’exploiter le protocole netbios pour adresser l’IPX800. Surtout lorsque la page qui s’enchaine après validation des propriétés réseau affiche
Your board is now located at: http://ValeurDuChampHostname/

Je ne comprends pas pourquoi vous ne passez pas l’ipx800 en IP fixe ou en bail statique sur le DHCP

Parceque je suis installateur et que fixer une IP fixe entraine des contraintes au moment de l’installation sur site (après préparation des équipements en labo).
L’IPX est quand même exploitable dans un réseau avec serveur DHCP ? non ?

une fois paramétré l’ipx800 en DHCP dans votre labo et transporté l’ipx800 chez le client, celle-ci reprend automatiquement une adresse dynamique sur le réseau client, ça je suis d’accord, ça fait gagner du temps. Mais une fois que l’IPX800 a obtenu sa nouvelle adresse, il suffit de transformer le bail en bail statique sur la box du client.
A partir de là, c’est gain de temps pour les accès futurs, y compris pour le client.
Quel que soit le domaine d’application, il est toujours conseillé et recommandé de paramétrer les serveurs en IP statique.

Ben ça ajoute une tache de plus dans l’installation (une de plus…). Y a pas de petite économies lorsqu’on cherche à « industrialiser » le processus d’installation.
Je trouverais ca incroyable qu’il faille en vernir à des techniques révolues depuis des lustres.
Pourquoi alors l’IPX800 propose l’option d’attribution d’adresse par serveur DHCP alors et surtout la possibilité de préciser un hostname (sans d’ailleurs spécifier que c’est exclusif à Netbios).

J’aimerais bien que quelque de GCE se prononce là dessus.

l’option DHCP facilite la 1ère connexion en remontant automatiquement tous les paramètres réseau. Mais une machine en client DHCP ne signifie pas forcément que sonadresse est dynamique, cela signifie seulement qu’elle lui est attribuée par un serveur d’adresses. Tout dépendra alors du type de bail que vous mettrez en place.

Vous pouvez rester en adresse dynamique, mais dans ce cas il faut un serveur de noms sur le réseau qui fera correspondre le hostname à l’adresse dynamique de l’IPX (Wins sous Windows)
Si vous passez l’IPX800 en IP Statique, alors l’ajout de l’information dans le fichier Hosts est suffisant (sous Windows)

Mais comme vous l’avez souligné, le Netbios n’est pas natif sous Linux.
Si vous souhaitez accéder au hostname d’une IPX800, à partir d’un pc sous linux, il faudra y installer les logiciels ou paquets nécessaires.

je ne sais pas de quoi vous parlez. Des IP fixes, j’en utilise des centaines tous les jours dans mon métier, et ce n’est pas obsolète du tout.