L'utilitaire de configuration ne trouve pas mon RF Player

Tout d’abord un grand merci pour la réception de mon RF Player ce matin, c’était la bonne surprise du jour :wink:

J’ai un petit soucis en lançant l’utilitaire de configuration, il me me met : « Can’t find RFPlayer, try in 2s »
Pourtant il est bien branché, sous windows j’ai un périphérique FT232R USB UART qui est détecté.

Merci pour votre aide !

Dans le gestionnaire de périphérique de windows 10, j’ai l’erreur :
Les pilotes de ce périphérique ne sont pas installés. (Code 28)
Il n’y a pas de pilotes compatibles pour ce périphérique.

Est-il possible de récupérer les drivers quelque part ?

Bonjour @berochet

Les drivers sont ici : https://ftdichip.com/drivers/vcp-drivers/

Débranchez le RF Player
Installez les drivers
Rebranchez le RF Player

Cordialement,

2 J'aime

Merci pour votre retour rapide.
Le RF Player a l’air d’être correctement détecté maintenant, en revanche j’ai une erreur en lançant l’utilitaire de configuration :

#
# A fatal error has been detected by the Java Runtime Environment:
#
#  EXCEPTION_ACCESS_VIOLATION (0xc0000005) at pc=0x000000007110b5db, pid=1196, tid=0x0000000000000c5c
#
# JRE version: Java(TM) SE Runtime Environment (8.0_281-b09) (build 1.8.0_281-b09)
# Java VM: Java HotSpot(TM) 64-Bit Server VM (25.281-b09 mixed mode windows-amd64 compressed oops)
# Problematic frame:
# C  [jSSC-2.8_x86_64.dll+0xb5db]
#
# Failed to write core dump. Minidumps are not enabled by default on client versions of Windows
#

Probleme avec Java il faut désinstaller toutes les versions de Java et reinstaller…

1 J'aime

prendre une version plus ancienne de java 8.
Ça a fini par marcher chez moi

Merci, ça fonctionne avec une ancienne version de java

Bonjour,

J’ai eu le même problème, j’ai d’abord installer le driver FTDI, puis comme conseillé nettoyage complet de java et réinstallation, mais toujours le même problème : la fenêtre du configurateur s’ouvre et se referme aussitôt génèrant un log d’erreur.
J’ai finalement désinstallé java puis réinstaller la version JRE 8u271, et là ça fonctionne parfaitement.
Donc le configurateur du RFPLAYER n’est pas compatible avec la dernière version 8u281 de Java.

1 J'aime

Bonjour @edouard ,

Merci pour votre retour, en effet il semble bien que le soucis soit présent dans la dernière version de Java.
A priori sera résolu avec la prochaine maj de Java… Je regarde quand meme si je ne peux pas faire un patch qui corrigerait ce bug.

1 J'aime

Bonjour,

J’ai également le problème avec la version 8u281, je l’ai donc complètement désinstallée pour réinstaller la version 8u271 et le problème reste le même. Dans le doute, j’ai même essayé la version 8u261, toujours sans succès. Je suis revenu à la version 271, voici le message d’erreur obtenu :

#
# A fatal error has been detected by the Java Runtime Environment:
#
#  EXCEPTION_ACCESS_VIOLATION (0xc0000005) at pc=0x000000007110b5db, pid=7272, tid=0x0000000000002958
#
# JRE version: Java(TM) SE Runtime Environment (8.0_271-b09) (build 1.8.0_271-b09)
# Java VM: Java HotSpot(TM) 64-Bit Server VM (25.271-b09 mixed mode windows-amd64 compressed oops)
# Problematic frame:
# C  [jSSC-2.8_x86_64.dll+0xb5db]
#
# Failed to write core dump. Minidumps are not enabled by default on client versions of Windows

Bonjour @ludokraft

Avez vous utilisez l’utilitaire Java pour tout désinstaller ?
Il doit rester des anciennes librairies car normalement cela aurait du marcher.

Je confirme que j’ai bien utilisé l’utilitaire de désinstallation Java et qu’il ne restait aucune ancienne version. J’ai même testé sur un 2ème PC qui lui n’avait pas Java, j’ai donc installé la version 271 et j’obtiens malheureusement la même erreur.

Curieux, vous êtes sur Windows 10?

Bonjour,
vous pouvez essayer ceci :

  1. Débranchez le RFPLAYER de son port USB, désinstallez le driver
  2. redésinstallez JAVA avec l’utilitaire en faisant un clic droit dessus puis « exécuter en tant qu’administrateur »
  3. lancez un utilitaire tel que CCleaner pour nettoyer votre base de registres
  4. ré-installez java en faisant un clic avec le bouton droit puis « exécuter en tant qu’administrateur » sur le logiciel d’install
  5. Réinstallez le driver « en tant qu’administrateur »
  6. rebranchez le RFPLAYER
  7. lancez l’utilitaire de configuration « en tant qu’administrateur »
2 J'aime

OK, j’ai réussi a démarrer l’utilitaire sur ubuntu. La version de java a utiliser doit etre strictement la Version 8 Update 281.

Le lien se trouve sur le site https://myrfplayer.com/

Aucune version plus récente de java n’est compatible a ce jour.

2 J'aime

Bonjour à tous
Suivez le petit tuto de fgtoul
plus ce petit condensé de liens importants ci dessous
pour vous éviter une journée de galère comme moi hier
pour faire fonctionner cet utilitaire !

url pour la Java 8 version 271 apparemment la version 281 pose dysfonction :
(impossible de trouver pour installer une précédente version sur le site Java d’Oracle)
https://java-2-runtime-environment.fr.uptodown.com/windows/telecharger/2915386

c’est quoi un fichier Java extension .jar :
ionos point f r (je l’écris comme ça car au moment de valider mon message
je n’ai le droit qu’à deux liens en tant que nouvel utilisateur ?)

nettoyage pc :
https://www.ccleaner.com/fr-fr/ccleaner/download/standard

J’ai réussi sous windows10

Mais je cherche toujours sous Linux Mint
je descendrai la version Java 281 vers 271 ??

2 J'aime

Voici les commandes exécutées sous ubuntu :
$ java -version
java version « 1.8.0_281 »
Java™ SE Runtime Environment (build 1.8.0_281-b09)
Java HotSpot™ 64-Bit Server VM (build 25.281-b09, mixed mode)

$ java -jar GCE_rfplayer_configuratorV1.6.4.jar

log4j:WARN No appenders could be found for logger (com.ziblue.rfxplayer.model.controller.SerialController).
log4j:WARN Please initialize the log4j system properly.
log4j:WARN See Apache log4j 1.2 - Frequently Asked Technical Questions for more info.

Merci Emma

J’essaierai quand j’aurai acheté du temps :slightly_smiling_face:

merci

Bonjour,
Je confirme que ca ne fonctionne pas avec les dernières version de java 8
cf Téléchargement logiciel RFplayer 1000 - Plugins - Communauté Jeedom
Ca marche sur windows 10 avec :
java version « 1.8.0_261 »
Java™ SE Runtime Environment (build 1.8.0_261-b12)
Java HotSpot™ Client VM (build 25.261-b12, mixed mode)

1 J'aime

Bonjour,
Chez moi, ça ne fonctionne pas non plus avec Java 1.8.0 261 (windows 10 à jour). J’ai un crash dans jSSC-2.8_x86_64.dll. Ce n’est visiblement pas la seule appli impactée. J’ai dû prendre le build 211 et ça fonctionne.