Lecture brute via modem USB teleinformation

Bonjour,

Je lisais ma téléinfo auparavant avec une clé USB qui a rendu l’âme il y a qq jours.
J’ai déjà qq scripts qui lisent de manière brute la trame des valeurs retournées par un cat /dev/ttyUSB0 et je n’ai pas vraiment envie de basculer sur une solution tout domotique.

J’ai reçu mon modem USB teleinformation ce soir, je l’ai branché et là c’est le drame : les trames qui sortent sont mal formées (certains retours chariots ne fonctionnent pas, les valeurs s’écrivent les unes sur les autres…)

J’ai bien compris qu’il s’agissait de paramétrer le modem via une commande stty

J’ai cherché un paramétrage correcte mais rien n’y fait : mes trames sont toujours du n’importe quoi.

j’ai deux questions :

  1. quelle la commande à passer via stty pour lire correctement les trames du compteur (1200 bauds, 7 bis, parité impair, 1 stop d’après la notice)
  2. On est bien d’accord que je lis sur le port(?) /dev/USB0 et qu’il n’est pas nécessaire de faire un lien symbolique vers /dev/ttyAMA0

merci d’avance pour vos réponses

Bonjour,

Vous avez acheté le modem USB sur notre site ?

Cdt

Bonjour,

Je l’ai acheté chez un revendeur (Amazon en l’occurence), j’ai trouvé l’adresse du forum sur la notice

cdt

Bonjour,

Rapprochez vous du support du revendeur Amazon.
Normalement ça doit marcher du premier coup…
Si vous ètes sur de votre câblage et de votre config c’est que le modem a un défaut et dans ce cas il faut le changer.

Cdt

Bonjour,

merci pour votre réponse.
J’ai identifié le problème : j’avais laissé sur le raspberry les paramètres de l’ancienne installation et c’est ce qui ne fonctionnait pas. En réessayant avec un système « neuf », le modem marche comme un charme.

1 J'aime