Module GCE Teleinfo: de nombreuses erreurs checksum?

#1

Bonjour à tous,

En utilisant un Raspberry pour récupérer les trames Linky configuré en mode Standard (9600 bds), je me suis rendu compte que de nombreuses trames ont des erreurs checksum. Pour rappel, le contenu de la trame et le checksum sont envoyés à la suite par le Linky.

Exemple de trame erronnée:

LTARF HDURE CREUSE (checksum K)

J’ai pourtant vérifié : le câble de connexion aux fiches I1/I2, le module de Teleinfo (le module de GCE electronics), l’isolation des câbles entre eux, un problème software sur le raspberry, etc.

Voici la courbe du nombre de trames (code+contenu) contenant une erreur checksum par minute, en fonction de la date de capture: https://ibb.co/q966nhZ

Le nombre d’erreurs explose juste avant minuit, et ceci sur plusieurs jours. Il y a des pics a 600 erreurs/minutes! Mais en moyenne on serait autour de 100 err/min environ. Je précise que je capture environ 2500 trames par minute, donc dans les pics, 24% des trames sont erronées…

Vu la régularité des pics, et la corrélation par rapport à l’heure du jour, je ne soupçonne pas le câblage (interférences) mais plutôt le Linky, voir le module lui-même: serait-il perturbé par la télétransmission des informations chaque nuit?

Avez-vous remarqué un comportement similaire chez vous?

Merci!

#2

Bonjour
Utilisez vous un cable blindé pour la liaison teleinfo avec le compteur ? Quelle longueur de câble ?
La régularité peut aussi provenir d’un appareil générant des interférences. Voyez ce que vous avez programmė la nuit.
Ces interférences peuvent transformer le signal transitant par le câble teleinfo si celui ci passe à proximité, sans blindage.
C’est souvent ce qui arrivent quand les utilisateurs reprennent les fils 1.5 mm2 de leur ancien compteur (hc/hp)
Cdt

#3
  • Non pas de câble blindé. Si vous pensez que c’est utile, je peux en acheter un
  • Deux câbles courts, de 1.5mm, de 10cm, juste de quoi aller du compteur Linky au module qui est juste en dessous
  • Il y a bien le ballon d’eau chaude mais celui ci est relativement éloigné du compteur (1m environ).
#4

sur 10 cm, c’est peu probable pour les interférences

#5

À mon avis c’est le Linky qui pose soucis…Le nombre de trame en erreurs qui augmentent en fonction de l’heure c’est pas bon signe. Pour confirmer il faudrait faire le test sur un autre Linky…

#6

Bonjour kit,

la liaison téléinfo est assez sensible… en impédance et en inductance.

Un câble de trop faible résistance peut être source de problèmes.
Enedis conseille dans ce cas :
Ce problème peut être résolu en plaçant entre les conducteurs du bus, à proximité de l’extrémité opposée à l’émetteur, une résistance d’amortissement (330 Ω à 1000 Ω ; 0,25 W).

Peut-être une piste à creuser.

Bonne journée

1 Like
#7

Bonjour à tous,

Je viens de tester la même installation avec un module concurrent et celui-ci n’a aucune erreur. Cela vient bien donc du module GCE qui n’est pas la bonne résistance à l’entrée du module…

#8

Bonjour,

Le module à une impédance d’entrée conforme à la norme enedis et il fonctionne très bien avec les compteurs Linky.
Dans ce cas votre module à peut être un défaut et dans ce cas il le retourner en sav.

cdt