Remplacer sur site les "0" et "1" des entrées par des image

Bonjour tout le monde,
je voudrais changer les 0 et 1 représentant l’état des entrées TOR, par des images un peu plus sexy, mais je bute:
voila ce que j’ai déja fait , si j’ai loupé quelque chose un avis pourrait me servir …
Digital Input

HTML: [b]

?   ?   ?   ?[/b]

JAVASCRIPT:
// Loop over all the buttons
for(i = 0; i < 4; i++) {
if(getXMLValue(xmlData, ‹ btn ›+i) == ‹ up ›)
document.getElementById(‹ btn › + i).innerHTML = ‹  ›;
else
document.getElementById(‹ btn › + i).innerHTML = ‹  ›;

Merci d’avance pour votre aide

j’oubliais, j’ai une IPX 800 V2 en 3.00.24, voici le code de la page, dés que je change le scipt pour afficher des images, je n’ai plus de retours des entrées.
index1.htm :

[b]IPX

Ma maison
Error:
Connection to relay board was lost.

Peut-être une erreur de syntaxe ou bien mauvais upload de la carte.

// Loop over all the LEDs
for(i = 0; i < 8; i++) {
if(getXMLValue(xmlData, ‹ led ›+i) == ‹ 1 ›)
document.getElementById(‹ led › + i).innerHTML = ‹  ›;
else
document.getElementById(‹ led › + i).innerHTML = ‹  ›;
}

Merci pour cette réponse rapide,
effectivement, je pense plus à une erreur de syntaxe, car quand je copie le code des leds aux boutons; je n’ai plus aucun retours même des états relais, je sèche un peu pour le coup…
j’ai regardé la méthode utilisée sur le site multicarte, mais je ne connais pas le php.
Mauvais upload? c’est à dire??
que devrais je verifier a ton avis?

Voici le code utilisé sur la version du site livrée en standard:

[b]// Loop over all the buttons
for(i = 0; i < 4; i++) {
	if(getXMLValue(xmlData, 'btn'+i) == 'up')
		document.getElementById('btn' + i).innerHTML = '0';
	else
		document.getElementById('btn' + i).innerHTML = '1';[/b]

et ma version:

// Loop over all the buttons
for(i = 0; i < 4; i++) {
if(getXMLValue(xmlData, ‹ btn ›+i) == ‹ up ›)
document.getElementById(‹ btn › + i).innerHTML = ‹  ›;
else
document.getElementById(‹ btn › + i).innerHTML = ‹  ›;

}

Par contre ce code pour les leds ( états des relais) c’est ok avec celui ci:

// Loop over all the LEDs
for(i = 0; i < 8; i++) {
if(getXMLValue(xmlData, ‹ led ›+i) == ‹ 1 ›)
document.getElementById(‹ led › + i).innerHTML = ‹  ›;
else
document.getElementById(‹ led › + i).innerHTML = ‹  ›;
}

Je ne comprend pas trop ce qu’il peut se passer…

Slt,

Voila moi j’ai remplacé les 1 et 0 dns la page d l iphone et un voyant d’état en plus.

Dom.

Error:
Connection to relay board was lost.

Merci à toi,
je vais m’inspirer de ton code, tu a de bonnes idées merci!

en compilant la nouvelle version de mon site , j’ai eu ce type de fenêtre:

dés que j’ai ce méssage, je n’ai plus aucune info venant de la carte, aucune entrée, ni états de relais.
Que faut il faire dans ce cas???
Merci de votre aide!

résolu,
j’avais déclaré des variables non utilisées!
voilà d’ou venait mon problème…