RT2 Sauvegarde ne fonctionne pas - BUG

Bonjour à tous, bonjour @Kevin_GCE @gce
La sauvegarde de la conf ne fonctione pas quand on va dans le menu mémoire sauvegarde.
Cela ouvre une page :

http://IPRT2/admin/download/config.gce

Celle ci affiche

!DEF

Est ce un bug ? Je suis en version 2.01.01

Dans le métier du développement logiciel, je trouve dommage que ces équipements soit « très light » au niveau des firmwares même si on sent une progression.
J’ai de nombreux petits bugs qui peuvent être bien gênants.
Exemple : Pas de login demandé à la mise en route.
Si on désactive / active l’accès sécurisé, ça efface le mot de passe admin. Il faudrait l’indiquer au moins dans l’interface si le fonctionnement est voulu.
Le système de login utilise une fenetre modale du navigateur qui peut poser souci dans certains cas. Pourquoi ne pas faire une vrai page HTML de login ?

Bonjour,

SI vous avez !DEF c’est que la mise à jour n’est pas bien passée.
Vérifiez vos versions web et firmware et refaites un hard reset.
Concernant vos remarques sur les petits bugs, nous faisons de notre mieux pour les résoudre au fur et à mesure que les clients nous remontent des anomalies.
Sans vouloir rentrer dans le technique, en embarqué nous n’avons des ressources limitées; On doit en permanence faire des arbitrages pour avoir un produit à un prix raisonnable, ayant un niveau de réactivité convenable et des fonctions sympas.

Cdt

2 J'aimes

Merci pour votre retour. Oui je comprends.
Par contre vous me parlez d’une mise à jour pas bien passé.
Mais je ne peux pas envisager de faire un hard reset sans pouvoir sauvegarder ma configuration et mes index. Mon système domotique derrière en a besoin… En revanche je n’utilise pas les historiques sur RT2.
Quelle solution pour contourner ?
Voici toutes les infos du panneau info :
Produit

ECODEVICES RT

Famille

X-Device

Mac

04:91:62:68:92:5D

Version logiciel

2.01.01

Version firmware

2.01.00

Bonjour,

La version logiciel devrait etre la meme que la version firmware.
C’est pour cette raison que vous avez le !DEF.
C’est pas prévu pour fonctionner de cette façon.
Le mieux est de noter vos index (par sécurité) puis de reinjecter le .bin en 2.01.00.
Ensuite retenter une sauvegarde de config.
Je ne peux pas vous garantir que ça fonctionne correctement car avec des versions différentes de web et de firmware, il y a un risque sde comportement erratique.

cdt

1 J'aime

Bonjour j’ai rechargé le firmware en 2.01.00.
Sans reboot, cela a fonctionné et les versions sont identiques. Je n’ai pas perdu ma config.
En revanche quand j’essaye de remettre le firmware 2.01.01, ça refait la même chose, version différente et impossible de faire le backup.

Dois-je rester en 2.01.00 ou quelle marche à suivre pour passer en 2.01.01 ?
merci

Bonjour,
sur le site de GCE la dernière version au téléchargement est en 2.01.00 d’où version firmware et logiciel identique.
Le firmware 2.01.01 c’est peut-être une bêta ne cours développement.

ok du coup c’est pas très clair. Il faudrait que @GCE puisse nous dire.

Bonjour,

Pouvez-vous m’indiquer l’endroit où vous avez trouvé cette mise à jour ?

Dans ce thread tout simplement

Ok,

La dernière release est effectivement la 2.01.00 sur notre site.
La version 2.01.01 a été sortie à partir de la 2.01.00 et nous lui avons ajouté la possibilité d’appairer des interrupteur enocean ainsi qu’un lecteur de carte Enocean à l’EDRT.
Une modification au niveau de l’historique a également été apportée.

Super merci
Y a t-il bien les 2 fichiers dans l’archive ?