X-GSM with free sim card

Bonjour,
J’a acquis une X-GSM et je n’arrive pas a la faire fonctionner…

  1. J’utilise une carte sim free et j’ai desactive le code pin.

  2. La carte semble reconnue (j’ai 3 bars)

  3. Etrangement quand je retire la carte sim meme en raffraichissant la page j’ai toujours 3 bars… (est ce normal?)

  4. Quand j’enregistre un numero, il s’affiche par defaut avec +336… meme si je rentre 06… (est ce normal?)

  5. Quand je rentre un numero etranger, ie: +9715… et que je rafraichis la page apres avoir fais un test, le numero etranger est modifie et le numero suivant apparait a la suite: ie +9715…+336… (est ce un bug?)

Bonsoir,

Il me semble qu’il faut absolument un code pin pour que le X-GSM fonctionne.

Bonsoir @joderic

J’ai aussi une carte sim free et bien avec un code pin désactivé.
Si votre achat de X-GSM est récent, vous pouvez aussi configurer et modifier le code pin:

Avez vous le message de confirmation : code pin valide meme si vous n’avez pas mis de code pin… (pour cela il faut rafraîchir la page)

Lorsque vous constatez cela, avez vous redémarré le système avec coupure d alimentation complète ?

Oui c’est normal. Il faut entrer les numéros au format international.

Avez vous bien enregistré les numéros avant de quitter la page?

Oui j’ai bien le message « code pin valide » .

Et j’ai bien enregistre mon numero international et apres avoir clique sur sauvegarder il est bien toujours la normalement. Par contre quand je rafraichis ou quand je quitte la page puis que je reviens dessus le numero change en +971xxxx+0033xxxx Est ce que ce module supporte bien de sauvegarder des numero internationaux? J’ai active l’option chez free pour me permettre d’emetre des sms vers l’international…

QQ a une idee?

Bonjour @joderic

Avez vous rafraichis le cache de votre navigateur ?
Est-ce que le numero etranger que vous voulez entrer comporte plus de 12 chiffres? Il semble que l’espace pour rentrer les numéros soit limité à 12 chiffres…

Je viens d’essayer la manipulation en entrant un numéro étranger en destinataire 2, je n’observe pas le comportement que vous décrivez

Bonjour et merci pour votre reponse rapide.
Oui j’ai rafraichis le cache du navigateur.
Le numero en comptant le « + » est en effet de 13 caracteres +971000000000 (j’ai change en 0 les vrais chiffres…).
Cordialement,
Yannick

Quand on rentre 13 caractères (en comptant le plus) il y a un moins qui apparaît…


Je vous conseille d’ouvrir un ticket d’amélioration sur le helpdesk

1 J'aime

Avez vous essayé avec 00971 à la place de +971 ?

Oui j’ai essaye avec 00971, rien n’y fait…

Ok maintenant j’arrive bien a envoyer et recevoir des sms de portables Francais avec ma sim card free. Par contre pour l etranger ca ne fonctionne pas, malgres le fait que j’ai active l’option avec free.
Pour le numero enregistre, apres avoir tout efface et re-initialise l’ipx plusieurs fois j’arrive a enregister mon numero etranger et j ai comme vous un - a la fin…
En tout cas merci.

Bonjour,

Quel est le pays vers lequel vous souhaitez envoyer des messages ?

Edit : Emirats Arabes Unis

Dans l’état actuel des choses, la X-GSM n’est capable d’enregistrer que 12 caractères pour les numéros de téléphone.
Je vais ouvrir un ticket en interne pour que les développeurs puisse regarder s’il est possible de faire en sorte d’enregistrer des numéros plus longs…

Petit test, est-ce que vous pouvez utiliser la commande API de l’IPX pour vérifier si la X-GSM est capable ou non d’envoyer un message vers un numéro étranger :
http://IPX800_V4/api/xdevices.json?key=apikey&SetSMS=+971512345678:ceci est un test

2 J'aime

Bonjour merci pour votre aide!
J’ai envoye la commande api et j’ai la reponse suivante:

{
    "product": "IPX800_V4",
    "status": "Error"
}

Bonsoir joderic,

juste pour vérifier que la syntaxe utilisée est la bonne, pouvez vous utiliser la même commande API sans le 8 à la fin du numéro.

Bonne soirée

Meme en enlevant le 8 (ou en reduisant mon vrai numero de 1 chiffre a la fin) j’ai le meme retour.
Qu’est ce que ca veut dire?

ça veut dire que votre commande API n’est pas rédigée correctement.

Si vous ne voulez pas la rendre publique, je vous suggère d’envoyer la commande exacte que vous utilisez @Kevin_GCE en MP pour qu’il la vérifie.

Bonne journée

Bonjour,

Pouvez-vous tester la même commande avec un numéro français (+336…) ?

En effet il doit y avoir un probleme avec ma commande car meme avec un numero Francais j’obtiens le meme…
http://adresseiplocalipxv4/api/xdevices.json?key=apikey&SetSMS=+336…:ceci%20est%20un%20test

Avez-vous une clef API paramétrée ? Si oui, vous devez la remplacer dans l’URL.

Autant pour moi… je n’avais pas mis mon apikey…
J’ai refais les test et maintenant j’ai:

{
    "product": "IPX800_V4",
    "status": "Success"
}

a la fois avec un numero Francais et mon numero des UAE.

1 J'aime