Connexion HTTPS sur ipx800 V5 via Freebox DELTA

Bonsoir, j’ai suivi les recommandations du wiki pour créer un certificat sur mon ipx800-V5. J’ai fait une redirection du port 443 entre le WAN et le LAN. J’ai utilisé mon nom de domaine donné par Free ainsi que mon adresse e-mail Free. J’ai une erreur de génération du certificat avec status CERT_ERROR_BAD_COMMUNICATION.

J’ai redirigé le port 80 et en HTTP avec mon nom de domaine je peux me connecter à l’IPX.
J’ai supprimé mon nom de domaine, je l’ai recréé. J’ai essayé toute sorte de redirection mais je n’y arrive pas. Je dois oublier quelque chose mais je ne trouve pas. Est ce que quelqu’un aurait généré un certificat en passant au travers d’une freebox Delta et pourrait m’aider ? Merci.

Bonsoir @alaindi ,

Vous avez bien redirigé le port externe 443 de votre Freebox Delta vers le port 443 de la V5? (Le message d’erreur me fait penser à une mauvaise redirection)

Bonsoir, je suis d’accord le message d’erreur m’a fait penser à la même chose mais j’ai bien fait la redirection. Je l’ai faite sur le port 443 mais aussi sur le 80. Quand je me connecte en http avec mon nom de domaine sur le port 80 j’arrive bien sur le login de l’IPX800-V5.

Bonjour, j’étais en version 5.1.1, je viens de passer en version 5.4.0 et ça ne fonctionne toujours pas mais je n’ai plus l’erreur CERT_ERROR_BAD_COMMUNICATION mais CERT_ERROR_CERTIFICAT_UNKNOWN


Avec telnet j’ai testé les ports 80 et 443 par le nom de domaine et sur le réseau local et ils répondent (pas d’erreur).
Y a-t-il des logs dans l’IPX que je pourrais consulter ?
Merci.

Re bonjour, j’ai désactivé mon firewall et j’ai ré essayé mais ça ne fonctionne pas, maintenant j’ai toujours l’erreur : CERT_ERROR_BAD_COMMUNICATION_FOR_CHALLENGE (c’est certainement le message que j’ai depuis le début, je n’avais pas vu qu’on pouvait scroller dans la fenêtre du message d’erreur)
J’ai cherché sur Internet la signification de ce message mais je ne trouve pas.
Cordialement.

Bonsoir @alaindi

Quand vous renseignez le nom de domaine, le fait vous bien précéder de http:// puis le nom de domaine?

Le nom de domaine a été crée il y a plus de 48h? voir 72h ?

Bonsoir, j’ai trouvé, le problème vient de Free.
Quand j’utilise le domaine que Free met à disposition xxx.freeboxos.fr, le domaine est accessible en local mais pas en externe (j’ai utilisé la 4G de mon mobile et je n’ai pas pu accéder au domaine). Par contre si je teste mon domaine sur « dnschecker » il trouve bien mon adresse IP fixe publique. Donc je ne comprendre pas pourquoi ça ne fonctionne pas avec ce nom de domaine.
Free met aussi à disposition une redirection DNS d’un autre nom de domaine intitulé xxx.hd.free.fr vers son adresse publique fixe. J’ai activé ce service. Sur « dnschecker » le domaine est bien redirigé vers l’adresse IP fixe publique. J’ai testé en 4G et cette fois ça fonctionne. Alors j’ai utilisé ce nom de domaine pour générer mon certificat et j’ai bien reçu un certificat actif.
Merci @Jweb de m’avoir aidé (je n’ai pas mis le http:// devant le nom de domaine dans la config de l’IPX et ça fonctionne).

Bonjour , bah moi cela ne marche pas , j’ai abandonné après


plusieurs tentatives :slight_smile:

Bonjour @artnow
Avez vous bien vérifié les pré-requis ?

Bonjour Jweb oui , je pratique la ipxv4 depuis longtemps et la V5 comme vous depuis quelques mois , je consulte les réponses et questions de tout le monde , je prends mon temps avant de poster une question car je me dit que la réponse est surement sur un tuto , mais là j’avoue que je suis dans une impasse , pas possible de me connecter à l’ipx 800 v5 si je ne suis pas à la maison avec le fai FREE , je fais surement une erreur mais dans ce cas un tuto serait le bienvenue pour celles et ceux qui n’arrivent à le faire . Merci la Team

Bonjour @artnow,

Avez-vous testé la méthode alternative en passant par un VPN vers le http://.
Ici très bon tuto de @fgtoul https://forum.gce-electronics.com/t/base-non-comprise-sur-v5/14132/12 et ça marche parfaitement.

Merci @Fgtoul , je vais tester merci , mais pourquoi nous n’avons pas un moyen plus simple pour se connecter ? la IPX reste quand même une box performante mais pour « « ingénieurs » » , Ce n’est pas toujours facile de se plonger dans la programmation , et les interactions à distance ou à domicile

Bonjour @artnow,
Je ne doute pas que l’utilisation de l’ipx800 va se simplifier au fil du temps.
Vous avez déjà vu arriver le Plugin V4 qui simplifie grandement la communication entre les différents modèles IPX, le Parser JSON, … D’autres évolutions continueront d’arriver, toujours dans le but d’enrichir les fonctionnalités et de simplifier l’utilisation, d’ailleurs il y a encore des demandes en attente et il y aura encore de très belles surprises.
Pour le moment, les bétatests sur évolutions et le forum nous prennent pas mal de temps, mais il est certain que lorsque du temps se libèrera, des Wikis et tutos verront le jour, d’ailleurs à ce sujet, toutes les bonnes volontés seront bienvenues :slight_smile:
Bonne journée

2 « J'aime »

Bonjour, désolé mais je n’ai pas eu le temps de vous répondre plus tôt.
Je pense que ce n’est pas l’IPX qui vous pose problème mais la config de la freebox.
Je vous décris ci-dessous quels paramétrages j’ai fait pour que l’appli Android IPX800 V5 fonctionne à distance (et pas seulement en local).
Vous devez vous rendre dans votre espace abonné freebox


Vous devez demander une adresse IP fixe V4 full-stack (dans mon cas je l’ai déjà)

Quand vous aurez cette adresse IP fixe vous la verrez dans ce menu


Ensuite il faut aller dans « personnaliser mon reverse DNS »

Et là, allez tout en bas pour paramétrer uniquement « l’entrée DNS personnalisée »

C’est fini pour le paramétrage de l’espace abonné freebox, vous avez maintenant une adresse IP V4 fixe et celle-ci est publiée dans les serveurs DNS sous le nom xxx.hd.free.fr
Attention ces paramétrages ne sont pas effectifs instantanément, il faut attendre plusieurs heures ou même un jour pour que ce soit publié.
Pour vérifier que votre nom de domaine est bien publié dans les serveurs DNS, vous pouvez le tester en allant sur le site https://dnschecker.org, vous entrez votre nom de domaine xxx.hd.free.fr

Ensuite il faut faire la redirection de ports dans la configuration locale de la freebox, allez dans http://mafreebox.freebox.fr, connectez vous et allez dans le menu « Paramètres de la freebox »


Passez en « mode avancé » et allez dans « Gestion des ports »

Redirigez le port 443 du WAN vers le port 443 du LAN sur l’adresse IP locale de votre IPX800 V5

Vous devrez avoir une nouvelle ligne de redirection de port comme celle-ci

PS : pas besoin de rediriger le port 80, je l’avais fait juste pour des tests

Maintenant il ne reste plus qu’à configurer l’IPX800 V5, allez dans le menu « système » puis « sécurité » et entrez le nom de domaine free : xxx.hd.free.fr et votre e-mail free xxx@free.fr (comme vous l’avez fait dans votre copie d’écran) et vous allez recevoir un certificat

Maintenant connectez vous avec l’appli Android IPX800 V5 de votre mobile en mettant en remote URL : xxx.hd.free.fr

Et ça doit fonctionner ! Vous voyez la complexité est plus du coté Freebox que du coté IPX :wink:

5 « J'aime »

Il est préférable de forwarder à l’extérieur sur des ports au delà de 1023
par exemple
Wan 10080 Lan 80
Wan 10443 Lan 443
Cela limite les attaques sur les ports conventionnels et diminue les problèmes avec le port forwarding upnp (certains logiciel ouvre grace à l’upnp de la box sur des ports conventionnels pour du ftp, service web cela peut faire doublon et vous empêcher de vous connecter de l’extérieur si le port 80 est déjà ouvert par une autre application)

Bonjour,
le port 443 doit être forwardé sur lui-même, comme fait par @alaindi, sinon l’obtention du certificat ne se fera pas.
image
Après obtention du certificat, il est alors possible de modifier le port WAN, mais il faudra le rétablir pour chaque renouvellement du certificat.
bonne journée

2 « J'aime »

Bonsoir,
c’est bien ça pour obtenir le certificat il faut faire comme je l’ai décrit.
Personnellement j’ai ensuite utilisé un port autre que le 443 pour l’IPX800 V5 android .
Mais je n’ai pas décrit cela dans mon explication car la première chose à faire est d’obtenir le certificat.
@artnow, lorsque vous aurez testé vous nous direz si cela fonctionne. Merci.

Bonjour ALAINDI , j’ai fait strictement ce qui expliqué ci-dessus , mon nom de domaine fonctionne , je l’ai tester sur le site . J’ai essayé 443 en tcp et 10443 en tcp , mais toujours rien .

Bonsoir @artnow , pour moi ça fonctionne bien. Pouvez-vous me faire des copies d’écran de vos configurations, je regarderai si je vois quelque chose de particulier. Si vous voulez vous pouvez m’envoyer ces copies d’écran par message direct. Cordialement.