Mise a jour IPX800 v3 avec nouvelle IHM

Bonjour,

Comme promis voici la nouvelle mise à jour pour la v3.
Une nouvelle IHM à été développé pour l’occasion.
Coté firmware on a simplement rajouté un mode particulier de gestion de volet roulant qui à été demandé par quelques clients.

Version complète du 13/11/2018 :
IPX800_3.05.74.zip (6,1 Mo)

4 J'aimes

Dommage j’en ai plus sous la main pour analyser le nouvel interface :sunglasses:

Bonjour Didierm,

j’en ai une à vendre… plus d’excuses :wink:

Bonne journée

2 J'aimes

@GCE, quelques retours :

  • La version mobile (index1.html) ne fonctionne plus. Faudrait enlever la redirection de index.htm ?
  • Les liens « push settings » et « mail settings » des outputs ne fonctionnent plus.
  • Ça serait bien de pouvoir fermer les modales des inputs/outputs en pressant Esc
  • Ça serait bien de pouvoir changer l’étant d’un input/output en cliquant dessus dans l’indicator-container
1 J'aime

En effet, c’est voulu dans le cas ou des personnes auraient des liens pré-configuré pointant vers cette adresse (Ne pas rechanger tout les liens).

Le lien n’est pas correct en effet. Je vais corriger ça.

Esthétique, non prioritaire (mais je vais voir pour l’intégrer).

Evolution non démandée.

Merci pour les retours.

2 J'aimes

Pas sûr de comprendre :thinking:

Pour l’instant, si j’entre l’adresse IP d’un des mes V3 sur mon iPhone, alors je suis redirigé vers index1.html qui n’existe plus et me retourne la page d’erreur « 404: File not found ».

Je suis obligé de rentrer IP/index1.htm pour que ça marche.

:+1:

Arf j’ai les yeux qui se sont croisés ! Je viens enfin de voir :dizzy_face:

Demain matin je redonnerais une version.

2 J'aimes

Voici la nouvelle version corrigé :

IPX800_3.05.72.zip (6,1 Mo)

Cdlt,

4 J'aimes

Bonjour,
Merci pour cette nouvelle IHM !
je rencontre cependant qq soucis sur les points suivant :

  • la modification du port d’écoute et couple : login / passwd dans l IHM M2M ne semble pas fonctionner
  • La sauvegarde de l @ IP fixe ne semble pas fonctionner suite réinjection conf : retour systématique par défaut 192.168.1.99

cdt

2 J'aimes

Bonjour,

Je viens d’installer la dernière version du 3/10 (6.1Mb) dans mon IPX 800 V3, j’ai remarqué quelques bugs :

  • la restauration de la configuration ne restaure pas les délais configurés en output (TA ON/OFF)
  • il est impossible de renommer le libellé du Input 8, c’est le libellé du Input 1 qui est modifié à chaque fois
  • la mise à jour via gcescandevice 2.02 est impossible si le port http configuré n’est pas 80
  • les paramètres de la partie DYNDNS sont renseignés avec des valeurs bizarre (dans mon cas une ancienne adresse de DNS pour le User et une valeur non consultable pour le password), on ne peut les effacer ni choisir de ne pas utiliser un service DYNDNS (pas de choix aucun dans la liste déroulante)
  • le paramètre Memory Mode d’Advanced settings n’est pas restauré
  • les paramètres SMTP ne sont pas restaurés
  • le mot de passe SMTP apparait en clair dans l’interface
    et enfin pour le moment :
  • je n’ai pas trouvé de menu pour sauvegarder/restaurer une configuration.
  • comment avoir accès à la page web de l’IPX via un smartphone/tablet android (le lien indique file not found) ? C’est bien utile quant on a que lui sous la main… (j’ai essayé avec Firefox pour Android)

J’aime beaucoup la nouvelle interface qui donne un coup de jeune à cet excellent produit.

Jérôme

1 J'aime

J’ai compris pour le lien sur android, il suffit de changer html en htm comme l’a dit ZogStriP…
En attendant une correction.

Plus grave : pas moyen de changer un timer…

exemple :

Je rentre un numéro de ligne, par exemple 100, j’appuie sur le bouton select, le résultat est :

  • le numéro de ligne 100 disparait de l’écran, le champ select est vide…
  • la ligne 1 s’affiche sauf que l’action à faire est à empty.

Mon IPX800 servant à gérer mon arrosage, je ne tiens pas à essayer de supprimer/modifier une ligne sans être sûr que cela marchera…

De base les pages étaient deja en .htm.

Je reviendrais vers vous quand à vos remarques.

Cordialement,

1 J'aime

Oui mais l’IHM ne retourne par la même page suivant l’environnement :

  • sous Windows 10 et Firefox/Edge/Chrome, elle retourne IPX800/index1.htm
  • sous Android et Firefox/Chrome, elle retourne IPX800/index1.html (qui ne marche pas…)

C’est bien une erreur de lien lié à l’environnement.

1 J'aime

Merci de lire plus haut, c’est ZogStrip qui l’a remarqué et c’est corrigé (03/10/2018)

Concernant votre problème voir le gif ci-joint

Comme vous pouvez le voir la ligne numéro 1 ne disparait pas…

Cdlt,

2 J'aimes

Par disparaitre, je voulais dire que la ligne (ici 1 dans votre gif) n’apparait pas dans les champs modifiables.

Dans votre exemple, la ligne 1 contient Monday/13:30/input2/ON
quand vous la sélectionnez, les champs modifiables contiennent Every Day/13:30/Input1/empty et le numéro de ligne 1 disparait du champ de sélection.

Du coup, je n’ose pas essayer une mise à jour de peur de perdre ma config en cours…

Désolé de ne pas avoir été assez clair.

Pour le lien htm/html sous Android, c’est bien la version en lien du 3/10 que j’ai installée et avec la quelle j’ai une erreur.

Je vais essayer avec un autre appareil histoire d’être sûr que ce n’est pas un problème de cache. A suivre…

Je viens de vider tous les caches et, effectivement, je n’ai plus ce problème, merci.

2 J'aimes

Dans mon problème de timer, si vous sélectionnez une autre ligne remplie (de 2 à 128), c’est toujours la ligne 1 qui s’affiche en partie (heure) dans les champs modifiables.

1 J'aime

Bonsoir
MAJ effectuée mais toujours des soucis depuis nouvelle version ( refonte IHM ):
Hostname non sauvegardé suite reinjection conf utilisateur - idem pour l @IP LAN choisit par l’utiisateur -> on obtient a chaque fois 192.168.1.99.
Le plus bloquant pour moi est coté M2M si on active le push vers un serveur le port et le login + passwd n est pluspris en compte ( IE ou firefox ) donc impossible de rétablir cette fonction suite a ces 2 dernières versions en.72

Merci pour votre prise en compte
cdt