Retour de 1ere experience avec Smart GCE et Google Home

Bonjour à tous!

Voila je n’ai pas résisté et des que le tout était dispo je me suis lancé !
Aprés quelques paramétrages … cela fonctionne très bien ! Et sur plusieurs IPX ! Il faut juste s’habituer au vocabulaire reconnu par les IA en ce qui concerne les lumières ou volets (ouvre / éteint / …)

Je commande le tout depuis mon smartphone sous Android et sans GoogleHome.
Que cela soit en 4G ou wifi local tout fonctionne bien pour ce qui est de mes tests pour l’instant limité aux volets (en ouverture uniquement), lumières et Sorties Virtuelles pour déclenchement de scénarios!

Le temps de réaction est plutôt bon !

4 J'aimes

Bonjour Jweb,

bravo :wink:

un petit tuto ? pour faire profiter la communauté :smiley:

Bonne journée

2 J'aimes

OK voici un début de tuto (en mode simple) que je complèterai au fil du temps:

  1. Mettre à jour son IPX800V4 minimum à la version 4.04.01

  2. Aller dans le menu de l’IPX800V4 : Réseau => Paramètres => activer le paramètre « Connexion à Smart GCE »
    Activer-connexion-smart-GCE

  3. Aller sur le site https://smart.gce-electronics.com/ et creer votre compte

  4. Une fois le fois le compte creer, commencez par appérer une IPX800V4 en utilisant le menu en haut à gauche « Mes IPXs »: nommez une IPX800V4 (ex: IPX Principale mais ne la nommez pas IPX800V4 car cela peut-être une source d’erreur) et déclarer son adresse MAC (que vous trouverez en mode admin dans le menu réseau => Paramètres : 3eme champ). Vous pouvez déclarer plusieurs IPX800V4 sans problème

  5. Ensuite sur le site smart GCE, commencez par déclarer un appareil en utilisant le « + » en haut à droite de l’ecran principal. Commencez par qq chose simple comme une lampe:


Nota :

  • Commencez par remplir le champ désignant votre IPX800V4 en la choisissant ds la liste des V4 déclarées: ds l’exemple ci-dessus IPX Principale

  • Le nuage permet de déclarer un objet temporairement hors ligne de Google Home lorsqu’il est désactivé. L’objet déclaré reste actif dans le service SmartGCE. (Un click sur l’icone effectue l’actions)

  • Un click sur l’icone permet d’effectuer l’action. (OFF l’icone est gris, ON l’icone est vert)

  • Vous pouvez modifier le Nom et le Surnom. Dans le monde Google le Nom est fixe et est hérité de l’objet directement. Dans le monde GCE, vous avez la possibilité de le modifier sans impact. Personnellement j’utilise le même Nom et Surnom

  • Pour appeler l’objet / la commande dans Google Home, vous devez utiliser le Surnom

  • un conseil: pour faciliter la déclaration d’objets ds le service SmartGCE, pensez à ouvrir ds un autre onglet la configuration des périphériques de votre IPX800V4 et assurez vous de bien repérer le bon numéro du relais ou de la virtuelle que vous voulez activer.

  • Pour l’instant le service est limité à l’utilisation des 32 premiers relais de votre configuration, et des 50 premières VO et VI. Enfin pour l’instant, les sources analogiques ne sont pas exploitables

  1. Si sur smartphone, téléchargez l’application GoogleHome

  2. Paramétrez l’application « Google Home » en créant une maison

  3. Allez dans les services, et choisissez Smart GCE et identifiez vous avec les identifiants choisis lors de l’ouverture du compte smartGCE

  4. Appairez le matériel remonté par le service SmartGCE à une pièce de la maison

  5. Y a plus qu’à causer au téléphone : Allume le lustre! Éteint le lustre! jour/ nuit ! :rofl: :grin:
    Nota:

  • Si vous donnez la commande Allume le Salon (et que le lustre et la prise commandée -par exemple- sont réunies dans la pièce salon) alors lustre et prise s’allument …
8 J'aimes

Bonjour à tous,

Merci pour ce tuto bien pratique.

Malheureusement pour m’a part, à chaque fois que je sollicite l’application vocalement via la google home, celle ci m’indique que smartGCE n’est pas disponible.

Je pense que mon lien en l’application GCE et mes automates ne fonctionne pas. Pourtant les déclarations avec mac adresse sont bonne sur la page web de smart GCE.

Je ne comprend pas trop !!

Merci pour ce tuto.
Cela fonctionne correctement à l’exception prêt est que lorsque j’active une lampe sur un relais X-8R (18 dans mon cas) via GH cela active aussi les relais 1 et 2 de l’IPX

Vous n’auriez pas un scénario qui active les relais 1 et 2 de l’IPX lorsque le relais 18 est activé par hasard ?

Non, surtout que les relais et 1 et 2 ne doivent pas être activé en même temps (monté / descente) d’un écran.
Je viens d’ajouter une seconde lumière et lorsque j’active la lumière via l’interface GH mon autre lumière s’allume en même temps. Je continue mes tests…

Avez vous déclaré le service smart GCE ds les paramètres de la Google Home? Vous êtes vous signé avec le service pour le rendre actif?

Bonjour Jweb,

Qu’attendez vous par signé?

Bonjour,

Pour information, je pense avoir résolu mon problème en désactivant l’ensemble des fonctions programmées dans IFTT.
Je vais continuer à alimenter GCE et continuer les tests.

A suivre.

Vous devez installer le service et l’activer en entrant login et mdp

Bonjour,

Les identifiants de connexion sont spécifiques à Google ou doit on prendre ceux du compte GCE ou des nouveaux ?

Bonjour @Francis

Pour ce qui est du service SmartGCE, vous devez créer un compte, donc vous pouvez avoir les identifiants de votre choix.
Je vous conseille de créer le compte directement sur le site SmartGCE et de parametrer au moins une IPX dedans
Puis de rattacher le service SmartGCE ds GoogleHome en utilisant les identifiants du service utilisés à l’étape ci-dessus.

@JWEB as-tu paramétré des volets ?

Oui j’en ai paramétré.
Petite astuce : il faut faire la commutation sur le ON/OFF d’une virtuelle. ex ON VO => monter; OFF VO => descente

Je m’en doutais un peu mais dans ce cas on ne peut pas indiquer un pourcentage de fermeture.

Je découvre comme vous. Je n’ai pas fait les beta tests… Pour ce que je vois, ce que je teste non effectivement je ne trouve pas le moyen d’indiquer un % d’ouverture ou fermeture … peut être en utilisant une VO pilotant un preset ds un scénario

Bonjour,

Pour l’IPX MINI cela ne doit pas fonctionner car il n’y a pas d’entrées et sorties physiques ?

J’ai été un peux vite, on peux. Je ne sai pas comment supprimer ce message

Cdlt

Bonjour,
Merci beaucoup pour les précisions apportées. Mais je n’arrive toujours pas à actionner ma porte de garage. La connexion avec Smart GCE est bien activée, les différents paramétrages semblent OK. Ma porte de garage est commandée par le relai 8 (Ta = 0, Tb = 5), cela fonctionne parfaitement depuis le dashboard V4.


Dans la commande Google Home j’énonce « OK google Ouvrir Porte du garage » ou « OK google Fermer Porte du garage ». La commande est comprise puisque GH me répond « OK, J’ouvre Porte du garage. », mais il ne se passe rien.
Il y a quelque chose qui m’échappe :thinking:
Qu’en pensez-vous ?

@ [Aspro95] vous avez bien mis à jour votre IPX et validé l’option dans la menu Réseau ?