Regulation piscine / PH-ORP X200Ph

Bon…la joie aura été de courte durée…

Depuis cette nuit, j’ai voulu faire un test « longue durée », sans electrolyseur, juste avec la filtration ON.

Et pour une raison totalement inconnue, puisque tout fonctionnait la veille, tout a déraillé…

Voilà le genre de graphe que j’ai désormais…

Des variations apparemment « régulières » de -150mV à +250mV environ.

Pour info, auparavant, avec exactement la même config, et sans avoir rien changé, j’avais ça : (avec filtration OFF entre 20h30 et 2h00…

Bonjour,
Voici le résultat de mes essais du WE :
Filtre GCE reçu et installé, tout est parfait les rares fluctuations sur le redox sont de l’ordre de 7mV, ce qui est très acceptable. Elles se produisent à intervalle régulier 1 à 2x par jour, pendant 1h environ.
J’ai enlevé l’alimentation linéaire à faible bruit, pour remettre en fonction l’alimentation à découpage fournie par GCE : aucun changement.
J’ai remis une sonde de température TC100 pour avoir la température de l’eau, aucun changement.
Ce filtre est donc indispensable et redonne tout son intérêt au module X200 qui peut être utilisé pour une régulation.
Quelques recommandations, que je formule en conclusion de mes travaux :
1/ avoir une bonne terre à disposition, j’ai mis un bon piquet de terre dans une zone humide et une connexion aux tuyaux de cuivre d’alimentation en eau.
2/ j’ai un pool de mise à la terre en inox en amont de la pompe et un second dans la chambre de mesure.
Ces 2 éléments éliminent les courants statiques qui se produisent inévitablement par la circulation de l’eau dans les tuyaux en plastique et qui viennent fausser les mesures.
Je n’ai pas opté pour la liaison avec la terre « électrique »
Ne pas oublier de mettre les pompes de traitement PH et désinfectant (Chlore) hors fonction en l’absence de flux d’eau. Les mesures sont aberrantes dans ce cas, et c’est obligatoire. Un détecteur de flux fait très bien l’affaire pour cela.
Pour ceux qui n’en ont pas je conseille la chambre de mesure et d’injection ZeliaPod, qui intègre tout.
Merci et bravo à GCE pour ce filtre.

Bonjour,
phr: excellente nouvelle, comme quoi on y arrive …C’est quand même un monde capricieux mais c’est ce qui en fait le charme!!!
Snoopy:
pourrrais tu me dire si tu avais une sonde ph lors de tes mesures? pourrais tu me donner la valeur de tension de ta sonde redox dans la chambre d’analyse avec un multimètre sans qu’elle soit reliée au x200ph.
Dans tous les cas tu as des valeurs très loin d’une bonne désinfection « 350mV » maxi, tu as combien en ppm de chlore libre. D’autre part, tu as un ph, sel,… de combien? Peux tu nous en dire un peu plus pour que l’on puisse t’aider.
Merci
Cdt

bonjour,
comment branche t’on un xbridge , un x200 , un x400 et le filtre pour x200 ?
peut on au moins faire cette combinaison ?

Bonjour,

il suffit d’intégrer le filtre juste avant le x200pH

cdt

1 J'aime

Bonjour,
Voici un exemple de branchements :

cdt

5 J'aimes

merci
pour ce schema tres explicite

Bonsoir à tous,
Je suis entrain de réfléchir pour réguler le ph de ma piscine avec mon ipx800 v4.
Pour la création de pompe doseuse en diy, que proposez vous ? Je souhaiterais partir sur du 24v ou 220v. (sauf si vous préconisez autre chose).

Si je prend un régulateur ph tout prêt du commerce, est il possible de ponter l’arrivée de la sonde ph vers l’ipx pour avoir un retour du ph sur le dashboard ?

Merci de vos retours.
À bientôt
Mickaël

Bonjour @Mika84,

"Si je prend un régulateur ph tout prêt du commerce, est il possible de ponter l’arrivée de la sonde ph vers l’ipx pour avoir un retour du ph sur le dashboard ?"

Pour avoir pas mal travailler sur le sujet « régulation pH Rédox ». Personnellement j’ai essayer mais il y 2 éléments importants qui risquent perturber.
–> les sondes doivent être raccordées sur des entrées de trés haute impédance car elles n’ont pas de puissance et la tension s’écroule très vite (R entrée> 100 MOhm) donc si vous la mettez sur 2 ampli en // vous allez diviser l’impédance équivalente.
–> Le principale pb que vous risquez rencontrer est simplement que la sonde pH à une inertie dans l’eau en contact avec la terre (et là les ennuis commencent) il faut une alimentation de chaque ampli de trés bonne qualité avec une séparation galvanique du réseau. D’autre part, la qualité de l’électronique n’est pas toujours au rendez vous. Donc attention!!!
–> Petit Rappel: les sondes pH donnent 0 mv à pH7, 53mV à pH8 et -53mV à pH6. donc pas facile de mesurer des valeurs entre pH 6,9 et 7,4.
J’ai résolue mes pb en mettant une sonde par ampli pour le pH et en utilisant des amplis de qualité pour la sonde rédox qui elle est avec anneau « or » pour une régulation par électrolyseur car l’embout « platine » donne des valeurs faussent dans ce cas.
Nota: le x200pH avec son filtre associé et l’isolation qu’il amène permettent d’obtenir des mesures de qualité seul pour le couplage il faut essayer.
cdt.

1 J'aime

Merci @Chris87.
Je vais partir sur une solution DIY qui donnera moins de problème.
Surtout qu’il y a de supers tuto sur ce forum :wink:

cdt

De mon coté, je tente toujours de faire fonctionner correctement mon module X200pH, sans succès pour le moment.

Il y a (peut être) eu une avancée…
J’ai tenté de connecter le module à une autre IPX800 V3 que celle de mon local technique, qui est chargé de gérer tout l’équipement piscine : PAC, filtration, électrolyse…). Cette autre IPX ne gère que des contacts secs pour ouvrir et fermer les volets de la maison : pendant mes tests, les valeurs avaient l’air bien plus stables.
Donc, je me demande si je ne devrais pas investir dans une 3eme IPX, qui serait dédiée aux mesures du X200pH, avec lui seul connecté dessus.

Qu’en pensez vous ? Le fait qu’il y ait des équipement électriques connectés à l’IPX au niveau des contacts ON/OFF peut il perturber la remontée d’infos du X200pH ?

Bonjour @snoopy10800,
avez-vous regardé du côté du filtre pour x-200ph ? sorti en 2017, il a été développé exprès et il coûte moins cher qu’une IPX . De plus il est vraiment très efficace !
http://gce-electronics.com/fr/ipx800-v4/1381-filtre-x-200ph.html


cdt

J’ai déjà mis en place ce filtre. Même si les variations sont moins importantes avec le filtre, les données envoyées restent inutilisables.

En revanche avec l’ipx « nue » ça a l’air beaucoup mieux…

Bonjour,

Je viens tout juste de mettre en service ma piscine que j’ai équipé d’un X-200PH + filtre avec sonde PH et Redox.
ça tourne seulement depuis un peu plus de 24h en « manuel » mais les courbes des mesures sous Jeedom permettent de mettre en évidence une variation de 35 mV (pic à 50mV) sur le Redox et de 0.01 (pic à 0.03) sur le PH.
Je vais maintenant essayer de diminuer ces variation sur le Redox en modifiant les mises à la terre:

  • terre « élec. » => actuellement indépendante mais je vais la raccorder à la terre « piscine »
  • terre « piscine » => actuellement sur un Pool terre unique à l’aspiration de la pompe auquel je vais ajouter le doigt de gant Inox de ma sonde de T° sur le refoulement.
    Dans quelques jour, j’aurai certainement plus d’éléments fiables à partager.

Cordialement.

1 J'aime

Bonjour @snoopy10800,@hf00,
Auriez vous un schéma exact avec positionnement des différents équipement raccordés sur l’IPX800 en cause , cela me permettrai de mieux évaluer les différentes causes possibles. Déjà quel type de chloration utilisez vous, les mises à la terre réalisées. Pouvez vous me dire le type d’alimentation DC12V utilisée, la longueur de ligne entre l’alim et l’ipx, avez vous pris la précaution de torsader la sortie 12V ou pas. Pourriez mesurer avec un multimètre la tenson du 12Volt en DC puis en AC (facteur de fluctuation et d’influence du 230V AC. cette valeur AC est en mVolt. Avez vous la possibilité d’essayer avec l’alim derrière un transfo 230/230VAC qui servirait d’isolement galvanique par rapport à la tension 230V.
Je vous posent beaucoup de questions mais pour résoudre ce type de pb il faut y aller petit à petit en notant tous les effets. Pour résoudre ce type de pb, il faut trouver la ou les causes. Pas de remède miracle mais plutôt une analyse bien structurée.
Je vous invite à lire ce post que j’avais écris:

vous pouvez me joindre en MP si vous voulez.

1 J'aime

Bonjour Chris87,
Encore un grand merci de t’intéresser à nos installations et nos soucis…

Malheureusement, je ne pense pas pouvoir t’aider avec mes mesures. En effet, je ne dispose pas d’un matériel suffisamment performant pour mesurer des mV. Je n’ai qu’un multimètre basique dont la précision est de 0,1V

Pour le reste, j’ai donc une chloration par électrolyse.
Distance entre alim et IPX : 10cm. (c’est l’alimentation format « tableau électrique » vendue par GCE)
Mise à la terre de la piscine via un pool terre et son piquet de terre dédié.
Mise à la terre du tableau électrique de la piscine via un autre piquet de terre dédié, à distance de l’autre.

Au niveau de l’alimentation, en DC, j’ai 12,1V. En AC, 0,0V (mais comme je le disais, je ne peux pas mesurer des mV)

Au niveau des entrées sur l’IPX, j’ai donc la filtration, la PAC (via contacteur de puissance), le pH-, et le système d’électrolyse.
Il y a aussi une extension X880 gérant mon arrosage, et une seconde gérant mes éclairages extérieurs. (j’ai déjà essayé de shunter ces extensions, sans résultat sur les remontées du X200pH

Vue la somme déjà engagée pour essayer de faire fonctionner correctement le système (module X200pH, filtre GCE, chambres d’analyse de modèle différents, sondes en X exemplaires, câbles BNC, mises à la terre différentes…, je me suis promis de ne pas dépenser un centime supplémentaire.

Je ne suis pas certain que ces maigres renseignements te permettront de te faire une idée du souci…

Bonjour,
Attention, pour le pool terre, concernant les piquets indépendants, on lit tout et son contraire.
Les assurances ne suivront que si l’installation est conforme à la NF C15-100.

Les terres ont-elles été vérifiées ?

  • résistance < 100 ohms (<20Ω pour supprimer tous les courants de fuite) ?
  • le sol est-il suffisamment humide ?

Vérifiez que vous n’avez relié aucun blindage de câble au ground de l’IPX ou d’une extension. Il vaut mieux connecter les écrans (avec ou sans drain) à la terre.

Avez vous tenté de connecter le blindage de la sonde ORP à la terre ?

cdt

Bonjour @snoopy10800,
le 1er des essais est de de relier ces différentes terre par fils car il suffirait de mettre un voltmètre en AC puis DC et de mesurer la tension entre les différents pool de terre. En mettant un câble les reliant vous ramenez ce potentiel proche de « 0 Volt ». La sonde redox est en contact avec l’eau (embout platine ou or) et mesure une tension.

vous faite la production de chlore à l’aide d’un électrolyseur et vous risquez dans tous les cas de ne pas avoir de mesure stable si votre sonde est avec un embout platine, il est préférable dans ce cas d’utiliser un embout or. La nature du chlore produit n’a rien à voir avec un chlore galet (style Javel).

J’ai fait l’expèrience sur 4 piscines ( personnelle et de mon entourage) à chaque fois les phénomènes se répétaient à savoir une valeur de 850 à 890mV pour 700mV réel (pH de 7,2 et Chl libre de 1,3) et une instabilité d’un jour à l’autre voir d’une heure à l’autre. Tout ceci avec des sondes de qualité style Hanna (160 euros) avec embout platine que j’ai toujours à la maison.

Cdt

1 J'aime

Bonjour,
Je suis entrain de programmer une pompe péristaltique pour baisser mon pH via les explications de @fgtoul, mais je bloque sur la création des cycles de fonctionnement et d’attente.
En suivant les recommandations des pompes doseuses du commerce, j’ai créé 4 scénarios afin d’incrémenter un compteur (CPT1) selon l’importance de l’écart du pH avec un cycle de 10 min. de fonctionnement.
Si pH sup. à 7.9 fonctionnement à 100% du cycle soit 3600 sec.
si pH entre 7.7 et 7.85 fonctionnement à 70% du cycle soit 2700 sec.
si pH entre 7.55 et 7.7 fonctionnement à 50% du cycle soit 1800 sec.
si pH entre 7.4 et 7.55 fonctionnement à 20% du cycle soit 720 sec.
Ainsi ma pompe est en marche tant que le compteur (CPT 1) a une valeur supérieur à 1 via une sortie virtuelle. si SV1 ON alors relais pompe doseuse sur ON.

J’ai créé également un autre compteur (CPT2) d’une durée de 10 min. qui va se lancer en même temps que le premier compteur (CPT1) est qui servira de cycle de fonctionnement de la pompe afin de laisser le temps à la sonde de récupérer les nouvelles infos et au ph moins de se diluer dans l’eau de la piscine.

A la fin du compte à rebours du compteur CPT 1, j’ai utilisé la règle suivante via des sorties virtuelles.
si CPT 1 = 0 et CPT 2 >= 1 alors mettre en OFF la SV 1 (et donc le relais de la pompe doseuse).
Par contre, à la fin du compte à rebours du CPT2, si je repasse la SV 1 sur ON alors ma pompe se remet en route.

Il y a forcement une erreur de conception quelque part mais je ne trouve pas la solution. Si une âme charitable peut m’aider ce serait sympa :wink:

À bientôt
Mickaël

Bonsoir,

Il est tout à fait possible de simplifier, tout en respectant les préconisations.

Vous utilisez CPT1 pour déterminer la durée de traitement maximum en fonction du PH, vous pouvez très bien déterminer une durée max unique par une tempo (SV). Lorsque le PH est OK durant le cycle Max, le traitement s’arrête, donc pas de risque. Par contre , si le PH n’est pas OK au bout du cycle Max, le traitement sera stoppé.

On peut définir une alternance de cycles de travail / Repos de 10 minutes chacun, par SV avec Tb=10 minutes, le tout ne pouvant dépasser la durée de SVcyclemax.
Ensuite, lorsque les 2 cycles Travail et repos sont OFF, on fait 1 ou 2 lectures successives. En fonction de leur valeur, on incrémente CPT2 (rebours) de la durée en prorata des 10 minutes de traitement qui aura lieu pendant le cycle travail (durée max). Les 10 minutes de repos sont systématiques avant le prochain réajustement en fonction de la valeur du PH.

on autorise la mesure du PH pendant le cycle maximum de traitement (évite surdosage ou traitement pendant baignade).

SI NON CycleTravail ET NON CycleRepos ET SVcycleMax Action[On/OFF] SVmesures

CPT2 peut être défini par 4 scènes successives qui fixent sa valeur en fonction du PH.

Si SVmesures ET NON SVx ET PH (7.85 ;7.9 ) Action[ON] CPT2(SET val=10 minutes) ;SVx
SI SVmesures ET NON SVx ET PH (7.7 ; 7.85) Action[ON] CPT2(SET val=7 minutes) ; SVx
SI SVmesures ET NON SVx ET PH(7.55; 7.7  ) Action[ON] CPT2[SET val=5 minutes) ; SVx
SI SVmesures ET NON SVx ET PH(7.4 ; 7.55 ) Action[ON] CPT2(SET val=2 minutes) ; SVx

SVx est utilisée pour ne pas fixer plusieurs fois le compteur,
en effet si l’ analogique PH(7.7 ; 7.85) est ON, alors PH(7.4 ; 7.55) l’est aussi.

SVx repasse OFF après CycleRepos, afin d’être disponible pour le cycle suivant.
SI NON CycleRepos OFF SVx

La gestion du relais (ne pas oublier de bien conditionner la mise en marche):

SI CPT2(>=1) ON/OFF SVrelais    
Si SVrelais ET SVcycleMax ET CycleTravail ON RELAIS 
SI NON SVrelais  OU NON SVcycleMax OU NON CycleTravail OFF RELAIS

N’oubliez pas qu’après tout traitement, la baignade est déconseillée pendant 2 heures.
Vous pouvez ainsi définir une SV qui s’active lorsqu’un traitement est nécessaire.
Si cette SV est ON, alors elle active une tempo de 2h dès que le traitement est terminé.
Cette tempo sera visible sur le dashboard.

Vous pouvez également vous inspirer de ce message. Après tout, traitement PH ou ORP, même bataille ! :wink:

Cdt